Welcome to Project 2002 please see the rules before joining our server

Installation Guide

Test Server

General chat and server information.
Trust
offline

 
Posts: 1180
Joined: Tue Sep 08, 2015 11:08 pm

Test Server

Postby Trust » Tue Jan 22, 2019 9:49 pm

Test Server Info

If anyone would like to try out the test server with all of the new patches and provide feed back, below is a list of various tasks that need to be verified to sign off on the updates.
  • * Standard Combat
    * Item Manipulation, e.g. swapping items, using banks, selling, trading, etc.
    * AA usage
    * Pet usage
    * Basic questing
    * Spell Casting
    * Grouping
    * Raiding
    * Overall Useability
    * General Feedback
In order to use the test server with all new code functionality, please use the following files. Download the package, install (This will only be used for test) and make sure to run the patcher (Included in the install folder). Same account information and character info was synced up about 2 days ago (1/20/19). Many of the GM commands have been enabled.

Test Server

Erleichda
offline

 
Posts: 104
Joined: Sat Apr 14, 2018 5:44 pm

Re: Test Server

Postby Erleichda » Thu Jan 24, 2019 5:37 pm

I went through and did a couple things for each item on the list there and spent some time generally dinking around.

-Combat, grouping, raid window, pets, casting, inventory management, spending and earning AA, turning in quests, buffing and debuffing all seemed to work fine.

-In the buffs part of the target window I could see buffs on other players, but not buffs/debuffs on NPCs. That function is past my time so I'm not sure how it's supposed to work.

-I had an issue using vendors. I couldn't figure out how to sell or buy from them. There seems to be a UI element related to 'sending' items that is on top of the UI element for buy/sell when I open the vendor window. The 'sending' thing is past my time so I'm not sure how it's supposed to work, but there's something screwy going with the UI buttons if nothing else.

-The target circles under NPC didn't reliably have the correct color related to how they con. Sometimes they did but sometimes they were just white (for mobs that definitely weren't even con). For example, drakes in ToV had white circles but bats in WFP had green circles.

-Some AA didn't transfer properly to test. For example, on my ranger I have 3 SoL and 3 PoP double ripose AA. The updated AA UI condenses these into a single AA category with 6 levels. Only the 3 from SoL carried over.

The #cast command isn't enabled for us on test. That's a nice one to have access to.

Trust
offline

 
Posts: 1180
Joined: Tue Sep 08, 2015 11:08 pm

Re: Test Server

Postby Trust » Thu Jan 24, 2019 8:36 pm

I went through and did a couple things for each item on the list there and spent some time generally dinking around.

-Combat, grouping, raid window, pets, casting, inventory management, spending and earning AA, turning in quests, buffing and debuffing all seemed to work fine. - Awesome

-In the buffs part of the target window I could see buffs on other players, but not buffs/debuffs on NPCs. That function is past my time so I'm not sure how it's supposed to work. - This will be removed

-I had an issue using vendors. I couldn't figure out how to sell or buy from them. There seems to be a UI element related to 'sending' items that is on top of the UI element for buy/sell when I open the vendor window. The 'sending' thing is past my time so I'm not sure how it's supposed to work, but there's something screwy going with the UI buttons if nothing else. Not seeing an issue here?

-The target circles under NPC didn't reliably have the correct color related to how they con. Sometimes they did but sometimes they were just white (for mobs that definitely weren't even con). For example, drakes in ToV had white circles but bats in WFP had green circles. Will Investigate

-Some AA didn't transfer properly to test. For example, on my ranger I have 3 SoL and 3 PoP double ripose AA. The updated AA UI condenses these into a single AA category with 6 levels. Only the 3 from SoL carried over. Will Investigate

The #cast command isn't enabled for us on test. That's a nice one to have access to. Fixed on next reboot.


Image

Erleichda
offline

 
Posts: 104
Joined: Sat Apr 14, 2018 5:44 pm

Re: Test Server

Postby Erleichda » Thu Jan 24, 2019 10:12 pm

I think you can probably disregard the targetting circle thing. I didn't realize 'grey con' was a thing and I was mistaking it for white con and then got confused about which mobs seemed to have the wrong circles after I logged off to write up what I saw.

This is what the vendor window looks like for me:
https://imgur.com/a/id2xq71
That parcels tab seems to be causing the problem.

Stationary tradeskill containers don't have a name on them, either in the updated tradeskill UI or in the old school 'experiment' container. Seems like a pretty minor issue but could cause a problem with the cultural forges. The combining worked fine though.

Trust
offline

 
Posts: 1180
Joined: Tue Sep 08, 2015 11:08 pm

Re: Test Server

Postby Trust » Fri Jan 25, 2019 6:02 am

I think you can probably disregard the targetting circle thing. I didn't realize 'grey con' was a thing and I was mistaking it for white con and then got confused about which mobs seemed to have the wrong circles after I logged off to write up what I saw.

This is what the vendor window looks like for me:
https://imgur.com/a/id2xq71
That parcels tab seems to be causing the problem.

Stationary tradeskill containers don't have a name on them, either in the updated tradeskill UI or in the old school 'experiment' container. Seems like a pretty minor issue but could cause a problem with the cultural forges. The combining worked fine though.
What vendor are you testing with? I cannot see the issue still

0000wiley3
offline

 
Posts: 185
Joined: Wed Feb 10, 2016 10:23 pm
Location: Cincinnati, Ohio - USA

Re: Test Server

Postby 0000wiley3 » Fri Jan 25, 2019 1:13 pm

According to his pic, that's:

Mirao Frostpouch

A vendor in Pok, -94 -213, near the eastern wall of PoK.

Is that the stock UI in your pic Erl?
Archi and the twins

Erleichda
offline

 
Posts: 104
Joined: Sat Apr 14, 2018 5:44 pm

Re: Test Server

Postby Erleichda » Fri Jan 25, 2019 4:30 pm

All the vendors are like that. The install is completely minimal. I downloaded the installer from drive and ran the patcher shortcut it sticks on the desktop.

I removed it and re-downloaded/installed on the off chance something got corrupted somehow, but it was the same.

I think someone else is going to have to download it and see what they get.

Trust
offline

 
Posts: 1180
Joined: Tue Sep 08, 2015 11:08 pm

Re: Test Server

Postby Trust » Fri Jan 25, 2019 6:24 pm

Re-run the patcher and test again. Also included some ported UI's.

Also Target buff issue should be fixed.

So that just leaves the missing AA's. I am looking into that

Erleichda
offline

 
Posts: 104
Joined: Sat Apr 14, 2018 5:44 pm

Re: Test Server

Postby Erleichda » Sat Jan 26, 2019 2:09 am

That fixed the vendor window.

Trust
offline

 
Posts: 1180
Joined: Tue Sep 08, 2015 11:08 pm

Re: Test Server

Postby Trust » Sat Feb 02, 2019 4:01 pm

To solve the AA issue (Due to AA reorganization required by the client to consolidate down to three tabs.) The best course of action was a full AA Refund and allow users to re-purchase what aa's they want.

I have applied the AA reset to the Test Server. All this does is add up the Banked and Spent aa's and set the banked aa's to this value. e.g. If you have 30 Banked AA's and 170 spent aa's you will have 200 unspent/banked aa's on Test.

I have adjusted the code for aa's so you can have more than 30 banked aa's but cannot gain any aa exp when over 30. This allows GM's to refund aa's without the possibility that you could lose them. As a bonus side-effect, this allows users to adjust what aa's they originally purchased.

Reminder, you must use the game files posted in the OP of this thread to access the Test Server.

Please test this functionality out, Additional fixed in place:

Innate Camo Fixed on Test
Bard Mez Running Bug fixed on Test


Return to “General Discussion”

Who is online

Users browsing this forum: Apple, Bing [Bot] and 1 guest

cron